Vim: si la version est spécifique, alors ne chargez pas le plugin

Je me request quelle est la meilleure façon de décider si un plugin doit être chargé en fonction d'une compilation / version spécifique de Vim. Toute aide serait appréciée.

Si vous voulez que cela dépende de la version, utilisez ceci:

 if version > 700 "do stuff for version 7 and up endif 

Si vous voulez vraiment savoir si une certaine command fonctionne, vous pouvez utiliser l'instruction exists :

 if exists('+breakindent') set breakindent endif 

Si c'est dans une interface graphique que vous vous intéressez, essayez if has('gui_running') ou mettez les commands dans .gvimrc .