sshfs – le noeud final de transport n'est pas connecté

Après avoir réinstallé le server, je ne peux pas le monter

sshfs root@domain.com:/var /remote_mount fuse: bad mount point `/remote_mount': Transport endpoint is not connected 

mettre à jour

 # ssh root@domain.com The authenticity of host 'domain.com (xxx.xxx.xxx.xxx)' can't be established. ECDSA key fingerprint is 57:b6:bd:76:17:80:73:85:4a:14:8a:6f:dc:fa:fe:7c. Are you sure you want to continue connecting (yes/no)? 

Votre SSHd n'a pas été configuré.

Faites-le d'abord et réessayez.

Après avoir utilisé sshfs pendant des années, j'ai juste trouvé cette erreur pour la première fois et j'ai trouvé cette page. Tout le "setup sshd" n'a pas été d'une grande aide car ssh a fonctionné.

Cependant, un peu de test a trouvé la solution. Le problème est survenu après une request de assembly sshfs échouée avec un nom d'hôte incorrect. Comme ls -l $mountpoint échoué avec cette erreur, j'ai essayé de fusermount -u $mountpoint le problème avec fusermount -u $mountpoint , et ça a marché!

Après l'échec, j'ai eu l'erreur sur un simple sharepoint assembly ls $ après l'échec de ssshf.

J'ai eu ce problème après avoir utilisé sshfs pendant un certain time. Cette réponse est pertinente uniquement pour les situations où sshfs a déjà été utilisé avec succès avant le problème.

Ce qui cause généralement ce problème est que vous avez terminé la connection il y a quelque time, et que le système a toujours le /remote_mount monté. Essayez d'abord de faire:

 sudo umount /remote_mount 

puis essayez de vous connecter à nouveau.