Paquets conservés lors de la mise à jour apt-get

Je cours Lubuntu 14.04.3 LTS version amd64. J'ai fait la apt-get update et la apt-get update apt-get upgrade qui montre que peu de packages ont été conservés. Il s'agit principalement de packages liés au kernel, à savoir linux-generic-lts-vivid , linux-headers-generic-lts-vivid , linux-image-generic-lts-vivid .

gardé en arrière

Tout ce que j'ai fait a été d'installer récemment la version de Lubuntu 14.04.3 et de faire la apt-get update && apt-get upgrade et ces packages conservés sont visibles.

Mes sources.list a trusty , trusty-updates trusty-backports , trusty-backports , trusty-security .

Alors,

  • Quand j'ai la version LTS d'Ubuntu, pourquoi Vivid apparaît-il dans la list des packages conservés?
  • Est-il sûr d'ignorer ces mises à jour? Y a-t-il des problèmes de security ignorant ces mises à jour?
  • Si je peux ignorer ces mises à jour, existe-t-il un moyen de masquer cette list chaque fois que j'exécute apt-get upgrade ?

Ce que vous voyez est un kernel rétroporté . C'est comme linux-generic-lts-vivid – qui est le kernel Linux de Vivid construit pour Trusty. Il est installé sur votre système, de sorte que vous avez un kernel plus récent que celui d'origine montré dans Trusty; vous avez donc installé une stack d'activation matérielle plus récente ou installé à partir d'une ISO Trusty ultérieure (l'ISO Trusty 14.04.3, par exemple, a le kernel mis à jour qu'il installe).

Il existe probablement des mises à jour de security pour le kernel, vous ne devez donc pas ignorer ces mises à jour. Si vous faites apt-cache policy linux-generic-lts-vivid vous pourrez voir à quel repository les mises à jour proviennent – soit un correctif (dans les trusty-updates ) ou une mise à jour de security (dans trusty-security ). Si c'est dans le repository de security, vous devez mettre à jour.

sudo apt-get dist-upgrade installera ces mises à jour du kernel.