mutt Protocole SSL inconnu – impossible à connecter

Je suis confronté à la situation suivante.

  1. J'utilise arch linux

  2. J'ai installé Mutt le client de messagerie

  3. J'ai suivi les directives simples dans le wiki arch pour configurer Mutt pour utiliser imap

  4. Pour la configuration simple où aucun ssl n'est utilisé, mutt essaye de se connecter via le nom d'user / mot de passe, après avoir entré le mot de passe dit Logging in....Login failed sans message d'erreur

  5. J'ai donc essayé de configurer Mutt pour utiliser SSL et fini avec cette configuration

    set ssl_use_sslv3 = yes set spoolfile = imaps://username@domain.de:993 set folder = imaps://username@domain.de:993/INBOX set mail_check = 10

Qui se retrouve avec l'erreur suivante:

SSL failed: error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol

D'autre part, j'établis une connection via openssl au server IMAP

openssl s_client -connect domain.de:993 -quiet

Le server de sharepoint terminaison est un Lotus Domino si cela est important.

Donc, je suis une sorte de naïveté à propos de ces erreurs.

Mettre à jour:

Le lien posté par @zelldon m'a aidé de cette façon que la définition de ssl_use_sslv3 m'a poussé à plusieurs pas en avant. Mais maintenant je me suis encore coincé au point 4 –

Eh bien, il s'est avéré que le nom d'user était incorrect. Je n'étais pas censé utiliser le nom d'user de l'adresse e-mail, mais plutôt, je devais utiliser mon nom interne à la place. Donc, cela a résolu le problème. Genre d'embarras: D