Debian 9 et RStudio

Je viens juste de passer à Debian suite à la sortie récente de la version 9. Je fais beaucoup de travail avec RStudio et j'ai donc essayé d'installer les versions stable et de test qui ont toutes deux échoué à cause de la bibliothèque manquante «libgstreamer0.10-0». Il semble qu'une version plus récente de ce package est installée mais que 0.10-0 n'est pas disponible dans l'extension. Existe-t-il un moyen d'installer RStudio malgré le package manquant? L'aide est très appréciée. Toutes mes excuses si ce n'est pas le bon endroit pour poser cette question.

OS: Debian 9
RStudio: 1.0.143-amd64

Modifier:

L'installation a été effectuée en utilisant gdebi.

Édition 2:

Après avoir installé libgstreamer0.10 et libgstreamer-base-0.10 comme décrit dans la question liée, j'obtiens maintenant libssl1.0.0 comme dépendance non satisfaisable dans gdebi.

Edit 3:

Obtenez lissl1.0.0 à partir d' ici et installez. Après cela, Rstudio s'installe et fonctionne correctement (je signalerai si je rencontre des problèmes).

Je pense que RStudio 1.0.143 est suffisant pour Debian 9. Il suffit de réparer quelques packages là. Faites et s'il vous plaît nous signaler ce que vous obtenez de l'étape (2)

  1. Correction libgstreamer0.10-0 problème libgstreamer0.10-0 comme décrit dans le fil ici
  2. libssl1.0.0 problème libssl1.0.0 .

    Télécharger libssl1.0.0 à partir d' ici

  3. Installez libssl1.0.0, installez Rstudio

  4. Profitez de Rstudio;)

Une version mise à jour de RStudio est disponible pour Ubuntu 16.04+ et Debian 9+ (tous les deux 64 bits seulement) sur leur page de téléchargement .

En utilisant cette version, l'installation se déroule sans problème avec sudo gdebi rstudio-xenial-1.1.350-amd64.deb sur Debian 9.1. 🙂

Autre réponse:

  1. Installez libgstreamer0.10-0 & libgstreamer-plugins-base0.10-0 selon la réponse acceptée ici
  2. cd dans le directory avec le file deb rstudio et Exécuter (remplacez XXX par la version du package):

     dpkg --ignore-depends=libssl1.0.0 -i rstudio-1.0.XXX-amd64.deb 
  3. Exécuter (remplacez nano par votre éditeur si vous le souhaitez):

     sudo nano /var/lib/dpkg/status 
  4. Trouvez l'input rstudio et supprimez libssl1.0.0 de la ligne Depends: ...

  5. Profitez de Rstudio

Les references:

Ignorer les dependencies lors de l'installation

Ingnore packages brisés