Comment installer la fusion 3.11 dans Ubuntu 14.04?

J'essaie d'get 3.11 pour travailler sur ubuntu 14.04

J'ai essayé de suivre la méthode ci-dessous "

cd ~ git clone https://git.gnome.org/browse/meld cd meld sudo ln -s ~/meld/bin/meld /usr/bin/meld 

Mais quand je cours dans le terminal, j'obtiens l'erreur suivante

 Traceback (most recent call last): File "/usr/bin/meld", line 223, in <module> setup_settings() File "/usr/bin/meld", line 197, in setup_settings cwd=melddir) File "/usr/lib/python2.7/subprocess.py", line 522, in call return Popen(*popenargs, **kwargs).wait() File "/usr/lib/python2.7/subprocess.py", line 710, in __init__ errread, errwrite) File "/usr/lib/python2.7/subprocess.py", line 1327, in _execute_child raise child_exception OSError: [Errno 2] No such file or directory 

Je ne suis pas sûr si son problème de dependencies ou problème de path python.

 #Make a clean working directory mkdir -p work/crap #Get in to that directory cd work/crap #Clone git head git clone https://git.gnome.org/browse/meld #Get in to that project directory cd meld #Install dependencies sudo apt-get install intltool itstool gir1.2-gtksource-3.0 libxml2-utils #Install meld sudo python setup.py install 

Si vous vouliez travailler sur le code lui-même sans réinstaller, je le fais généralement en installant dans un venv et en ouvrant le dossier installé dans le venv dans un IDE.

Résultat de la fusion d'un terminal après ces étapes:

entrer la description de l'image ici

Notez que la version actuelle de meld nécessite GTK + 3.14, qui n'est pas disponible sur Ubuntu 14.04 ( Meld requires GTK+ 3.14 or higher. . Donc, pour Ubuntu 14.04, vous devez vérifier la dernière version qui n'a pas besoin de GTK + 3.14. C'est la fusion 3.14. * Branch (actuellement 3.14.3), donc checkout la twig en utilisant git checkout meld-3-14 .

J'ai trouvé meld 3.12 disponible dans le référentiel ubuntu 14.10.

L'installation du package deb fonctionne même sous 14.04

http://packages.ubuntu.com/utopic/all/meld/download